Terrascope logo Proba-V MEP logo
This forum applies to Terrascope and Proba-V MEP. Please note that the forum is in English only.
Please log in using the link in the top menu to add new forum topics or comments.

General discussion

ConnectionError: ('Connection aborted.', RemoteDisconnected('Remote end closed connection without response'))

Hello, I use the API Query Global Land product catalog to download hourly LST data; but every few moments I get a connection error  (ConnectionError: ('Connection aborted.', RemoteDisconnected('Remote end closed connection without response'))) that interrupts my download, I don't know what is the problem. Please can someone help me fix this problem. Thank you for your help 

Error during installation with pip - terracatalogueclient

Hi everyone, I've used terracatalogueclient so far and have never experienced any issues. I've used it in my dockerized app and my Dockerfile looks like this: RUN pip install --extra-index-url https://artifactory.vgt.vito.be/api/pypi/python-packages/simple terracatalogueclient as specified in the official Github documentation. But for some reason this is no more working. Does anyone know why? Thank you. 

Sentinel 2 image size

Hello everyone, I'm using Terrascope's jupyterlab in order to analyze the NDVI, NDBI and NDWI of a certain area over a time range. While analyzing the selected files, I noticed that while I selected the same AOI everywhere, I don't get the same image shape every time and the area observed in my image is not the same. To make my problem clearer, I have attached my code here: https://we.tl/t-jtpM5Is9W8   In the last cell, the different shapes of the considered files are printed. Do I have to isolate my AOI in another way, because I thought that using mask.msk only the aoi is considered?

TimeseriesDemo notebook error

I'm using the demo notebook 'TimeseriesDemo.ipynb' to try and get Sentinel-1 timeseries. However, upon running requests.get(''https://services.terrascope.be/timeseries/v1.0/ts/''), I get an error code 500 and the following error message: "unknown OpenSearch collection BCGMS_NDVI300". I did not change anything in the notebook, so I'm confused as to why I am receiving this error. Can you help me solve this issue? Thanks!

Could terrascope download the S5P PAL dataset?

Due to an inconsistent of different version of TROPOMI NO2 data set, the TROPOMI official has reprocess the NO2 data  which is the PAL data( https://data-portal.s5p-pal.com/).  In tropomi offical site ,it says(http://www.tropomi.eu/data-products/nitrogen-dioxide/): The upgrade to version 2.2.0 (5 July 2021) leads to an increase of the tropospheric NO2 columns for cloud-free pixels and the previous upgrade to version 1.4.0 (2 December 2020) led to a substantial increase in the observed tropospheric NO2 column amounts over polluted areas for scenes with small cloud fractions. For time series, trend studies or comparisons between years the results versions should not be mixed without accounting for these changes, as the series would show artificial (positive) jumps. The PAL data is very important for studying the long-term trend. So, could the terrascope download the TROPOMI PAL data for users? I notice that now only have the old version data in the VM's.  Many thanks.   Sincerely, Mitch Zhang


Is it possible to perform  a complete PSInsar worflow in Terrascopre VM?   

401 on downloading WorldCover Products (urn:eop:VITO:ESA_WorldCover_S1VVVHratio_10m_2020_V1 & urn:eop:VITO:ESA_WorldCover_S2RGBNIR_10m_2020_V1)

It is possible to download urn:eop:VITO:ESA_WorldCover_10m_2020_V1 products. Everything works fine. It is, however, not possible to download urn:eop:VITO:ESA_WorldCover_S1VVVHratio_10m_2020_V1 or urn:eop:VITO:ESA_WorldCover_S2RGBNIR_10m_2020_V1 products, the HTTP response code being 404.   This seems to be an authorization issue (HTTP 404) but, on the other hand, the construction of the first URL seems to be a little different (in respect to the other URLs). Please help me understand if/how it would be possible to download the S1VVVHratio_10m_2020_V1 and S2RGBNIR_10m_2020_V1 products. https://services.terrascope.be/download/WORLDCOVER/ESA_WORLDCOVER_10M_2020_V100/MAP/ESA_WorldCover_10m_2020_v100_N39E000_Map/ESA_WorldCover_10m_2020_v100_N39E000_Map.tif https://services.terrascope.be/download/WORLDCOVER/ESA_WORLDCOVER_10M_2020_V100/S1VVVHRATIO/ESA_WorldCover_10m_2020_v100_N41E001_S1VVVHratio.tif https://services.terrascope.be/download/WORLDCOVER/ESA_WORLDCOVER_10M_2020_V100/S2RGBNIR/ESA_WorldCover_10m_2020_v100_N49E005_S2RGBNIR.tif

downloading Sentinel-2 Data Products (urn:eop:VITO:CGS_S2_L1C)

  There seems to be a difference between Sentinel-1 and Sentinel-2 when it comes to downloading the product (as a .zip file) and opening it with ESA's Snap application. The S1 products are downloadable as a zip .file. The URL of this file is present in the response payload for a search (path: features.properties.links.data.href).   URL of the search: https://services.terrascope.be/catalogue/products?collection=urn:eop:VITO:CGS_S1_SLC_L1&collection=urn:eop:VITO:CGS_S1_GRD_L1&start=2021-12-29&end=2022-01-06&geometry=POLYGON((6.352433189749719%2049.90370356672262,%206.457901671528817%2049.90370356672262,%206.457901671528817%2049.949002521470284,%206.352433189749719%2049.949002521470284,%206.352433189749719%2049.90370356672262))   URL of the .zip file: https://services.terrascope.be/download/CGS_S1_SLC_L1/IW/DV/2021/12/30/S1A_IW_SLC__1SDV_20211230T055052_20211230T055119_041234_04E67C_EBE5/S1A_IW_SLC__1SDV_20211230T055052_20211230T055119_041234_04E67C_EBE5.zip   The product can be open in Snap.   The S2 products (only tried for urn:eop:VITO:CGS_S2_L1C) are downloadable as a collection of individual files.   URL of the search: https://services.terrascope.be/catalogue/products?collection=urn:eop:VITO:CGS_S2_L1C&startIndex=1&count=10&start=2021-12-30&end=2022-01-07&geometry=POLYGON((6.284214053303004%2049.892271728044,%206.330356765538455%2049.892271728044,%206.330356765538455%2049.93758147405905,%206.284214053303004%2049.93758147405905,%206.284214053303004%2049.892271728044))   URLs of some files (3 out of 104): https://services.terrascope.be/download/CGS_S2_L1C/2022/01/02/S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621/S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621.SAFE/GRANULE/L1C_T31UGR_A025202_20220102T104336/QI_DATA/T31UGR_20220102T104339_PVI.jp2 https://services.terrascope.be/download/CGS_S2_L1C/2022/01/02/S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621/S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621.SAFE/manifest.safe https://services.terrascope.be/download/CGS_S2_L1C/2022/01/02/S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621/S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621.SAFE/GRANULE/L1C_T31UGR_A025202_20220102T104336/IMG_DATA/T31UGR_20220102T104339_B03.jp2   There is an endpoint that allows for the download of the files (indicated as the payload of the HTTP POST request): https://services.terrascope.be/package/zip I noticed this endpoint by means of reverse-engineering, analyzing the "viewer" application in the browser. There seems to be no documentation on this endpoint. It would be great to have more info, it would be great to know if (and how) it could be parametrized/configured.   The result of this call is a .zip file. However, this .zip file presents some issues and it is not usable as such: Snap cannot open the Terrascope product, neither the desktop application nor the Java lib. I tried to manually adjust (as described below) the .zip file, still, I cannot open it with Snap.   The following analysis is made by comparing the same product downloaded from two providers Terrascope and Creodias.   URL of the search (Creodias): https://services.terrascope.be/catalogue/products?collection=urn:eop:VITO:CGS_S1_SLC_L1&startIndex=1&count=10&start=2021-12-29&end=2022-01-06&geometry=POLYGON((6.352433189749719%2049.90370356672262,%206.457901671528817%2049.90370356672262,%206.457901671528817%2049.949002521470284,%206.352433189749719%2049.949002521470284,%206.352433189749719%2049.90370356672262))   URL of the .zip file (Creodias): https://zipper.creodias.eu/download/74a8f296-e256-5806-b0e7-709b56f259b4     The inner path of the  file: Creodias: S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621.SAFE\MTD_MSIL1C.xml Terrascope: CGS_S2_L1C\2022\01\02\S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621\S2B_MSIL1C_20220102T104339_N0301_R008_T31UGR_20220102T113621.SAFE\MTD_MSIL1C.xml Changing the inner path, alone, does not fix the problem. It might be, however, a required step.   Compressing method: Creodias: the inner directories and files are not compressed, the size and packed-size values are equal. The method is Store. Terrascope: the inner directories and files are compressed, the size and packed-size values are different. The method is Deflated for files, not declared for directories. Changing the compressing method (meaning to archive but not compress the files) still does not fix the problem.   Attributes/Permissions of the inner directories and files: Creodias: directories: D drwxrwxr-x & files: -rw-rw-r-- Terrascope: no attributes It might be an issue of file-visibility. Snap manages to see the MTD_MSIL1C.xml file and the GRANULE directory, but cannot see the children-files of GRANULE.  

404 on downloading Sentinel-2 Data Products (urn:eop:VITO:CGS_S2_L1C)

I am not able to download Sentinel-2 Data Products (urn:eop:VITO:CGS_S2_L1C). I tried using the browser, Postman, the Python client and the web-service through a Java client. The response is always the same "404Not Found".   For example, the product "S2A_MSIL1C_20220102T001111_N0301_R073_T55HFA_20220102T013405" points to the following URL: https://services.terrascope.be/download/CGS_S2/CGS_S2_L1C/2022/01/02/S2A_MSIL1C_20220102T001111_N0301_R073_T55HFA_20220102T013405/S2A_MSIL1C_20220102T001111_N0301_R073_T55HFA_20220102T013405.SAFE/GRANULE/L1C_T55HFA_A034104_20220102T001111/IMG_DATA/T55HFA_20220102T001111_B03.jp2   On the other hand, with the same credentials, I am able to download Sentinel-1 (urn:eop:VITO:CGS_S1_GRD_L1 & urn:eop:VITO:CGS_S1_SLC_L1) and Sentinel-2 (urn:eop:VITO:TERRASCOPE_S2_TOC_V2 & urn:eop:VITO:TERRASCOPE_S2_CCC_V2).   Any help would be very much appreciated.

Looking for information?

Find our documentation on:

stay up to date!
subscribeto our newsletter
new perspectives

Stay up to date!